no such file to load -- openssl (RuntimeError)

Mongrelを起動しようとして
ruby script/server

したら
/usr/local/lib/ruby/gems/1.8/gems/rails-2.2.2/lib/initializer.rb:259:in `require_frameworks': no such file to load -- openssl (RuntimeError)

となって起動しない。
rails で「no such file to load -- openssl」 てエラーについて - はたはたを参考に
cd /usr/local/src/ruby-1.8.6/ext/openssl/
ruby extconf.rb
までしたところでエラーが出てMakefileが作成されない。

どうやらopenssl-develが必要なようなので
yum install openssl-devel

インストールされたら再び
cd /usr/local/src/ruby-1.8.6/ext/openssl/
ruby extconf.rb
make
make install
で再度起動すると今度はOKでした。


タグ:Rails
posted by digital-squad at 2009年03月27日 12時05分 | Comment(0) | TrackBack(0) | Ruby on Rails / Ruby
この記事へのコメント
コメントを書く
お名前: [必須入力]

メールアドレス:

ホームページアドレス:

コメント: [必須入力]

認証コード: [必須入力]


※画像の中の文字を半角で入力してください。
※ブログオーナーが承認したコメントのみ表示されます。

この記事へのトラックバック
×

この広告は180日以上新しい記事の投稿がないブログに表示されております。